OSD Lyrics 0.4 正式发布
OSD Lyrics + 豆瓣电台

OSD Lyrics 0.4.1 发布

Tiger Soldier posted @ 2011年7月19日 16:14 in osd-lyrics with tags osd-lyrics , 6182 阅读

OSD Lyrics 0.4.1发布,加入一些0.4.0没来得及实现的特性:

  • 启动时选择播放器
  • 修复千千静听下载
  • 增加虾米下载支持
  • 搜索多个下载站点
  • 桌面歌词边缘模糊
  • 支持所有MPRIS播放器

启动时选择播放器

之前OSD Lyrics的设计是在启动时若没有支持的播放器,则自动退出。这个设计很不方便,也让很多用户一头雾水。后来为了方便用户,可以设置在启动时自动启动播放器。但是对于第一次启动或者没有设置过启动播放器的用户来说,OSD Lyrics启动后自动退出依然是一个让人无语又无奈的行为。在0.4.1里我终于有时间有精力有兴趣把这个脑残的设计给纠正过来了。

在启动时,如果没有检测到支持的播放器,又没有设置自动启动的播放器,或者是启动播放器但是失败了,那么OSD Lyrics会弹出一个播放器选择的界面:

播放器选择界面

很抱歉到现在才把这玩意给做出来。

歌词下载相关

由于千千静听的域名变动,0.4.0的歌词下载暂时失效,现在已经修复了。

另外增加了虾米的下载支持。由于虾米的搜索时间比较长,而且搜索的匹配效果一般,不建议作为首选站点使用。

群众呼声最高的多站点下载支持也在此版本中实现了。现在可以在首选项中选择要使用的歌词站点及其顺序,搜索时会依次搜索,当一个搜索不到时会自动搜索下一个站点。

边缘模糊效果

给桌面歌词的边缘加上了高斯模糊效果:

歌词边缘模糊

大家觉得是不是好看了点呢?

要启用边缘模糊,需要歌词轮廓宽度大于0。在0.4之前默认宽度为0(其实这是一个bug),0.4之后默认为3。

如果不喜欢边缘模糊,或者觉得边缘模糊在切换歌词时会卡,可以在首选项中将模糊程度调到最弱将它关闭。

更好的MPRIS支持

OSD Lyrics现在可以支持所有正确实现了MPRIS v1协议的播放器了。这意味着,如果一款播放软件实现了MPRIS(v1或者v2均可),即使它不在OSD Lyrics支持的播放器清单中,照样可以使用OSD Lyrics来给它显示歌词。

顺带一提,很多朋友提到过支持DeadBeef,之前由于它没有提供DBus接口而作罢。现在有人给它开发了MPRIS扩展,使用该扩展就可以了。

下载

源代码包和openSUSE安装包已经在下载页面中提供,更多安装包将陆续放出。

豆豆 说:
Jul 20, 2011 05:40:29 PM

顶!!!希望deb包尽快OK,以方便我们这种UBUNTU用户

感谢楼主 说:
Jul 20, 2011 08:23:41 PM

非常感谢楼主为我们linuxer提供这么好的软件。如果能整合一个歌词编辑和调整那最好了。谢谢楼主。

Avatar_small
Mike Ma 说:
Aug 10, 2011 10:04:50 PM

希望能支持 RhythmCat,这个播放器支持 DBus 的。

@感谢楼主: RhythmCat 的插件支持歌词编辑和显示。

剑崎·目 说:
Oct 01, 2011 12:58:56 PM

好久没网络更新Ubuntu,发现osd-lyrics更新成了0.4.1,不过没留意Rhythmbox是否更新了,版本为0.12.8,系统为10.04。打开osd-lyrics同时也启动了原来设定好的Rhythmbox,不过过了一段时间弹出选择播放器的窗口,选择了过了一会还是出现,试了无视直接播放歌曲,osd-lyrics不工作。终端输入osdlyrics -d debug运行,一直有拒绝连接的提示。

lightning1141 说:
Nov 08, 2011 08:48:21 PM

顶!不过我的fedora15装的fedora14的rpm包
yum check 错误如下:

osdlyrics-0.4.1-1.fc14.x86_64 有缺少的需求 libnotify.so.1()(64bit)


登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter